8 (800) 100-20-59
Можно связаться через

Исправление уязвимости Bash (Shellshock)

Для исправления уязвимости shellshock CVE-2014-6271 и CVE-2014-7169 в bash необходимого его обновить до последней версии.

Для каждой ОС обновление производиться по разному:

Centos

Нужно выполнить обновление через менеджер yum

yum update bash

Debian 7

Выполняем команду:

apt-get update

После этого запускаем обновление Bush

apt-get install bash

Debian 6

Открываем для редакции файл /etc/apt/sources.list

Добавляем в него следующую запись

deb http://ftp.us.debian.org/debian squeeze-lts main non-free contrib

После выполняем команду

apt-get update

И делаем обновление самой Bash

apt-get install bash

Проверить наличие уязвимости на вашей версии можно простой командой:

env X=”() { :;} ; echo busted” bash -c “echo hello”

Сервер Вам выдаст ответ:

busted
hello

Эта запись была опубликована в рубрике Школа хостинга. Добавить в закладки ссылку.